Paydirt Home Locations Permit Map Equipment & Services Gold Price Old Forum Archive Donate Search

My p90 wont suck water

anyone had this problem …set up my gxh50 p90 water pump prime theinlet hose foot valve all clear just wont suck water…everything was working fine during last run

Pull the pump apart , there could be gravel inside the pump , check all the hose clamps could be sucking in air .

1 Like

thanks mate will do i am just about to unscrew pump and look

Yep like sooty says. More than likely an air leak somewhere or possibly the internal ceramic seal is buggered.

2 Likes

sounds like you are sucking air

1 Like

the sound of slurping while sucking is not good . you need a good seal . not one from the sea . but haven’t tried so maybe a nz fur seal will work

2 Likes

just pulled pump apart and without taking impeller off i can see there are no gravels in there and motor is brand new so i think ceramic seal not from the sea should be fine…was just really strange primed it checked hose clamp hose free of blockage…will try again…thanks for all help you guys are awesome…thanks so much

ha i pull the pump apart and cant find anything ??? no debri put pump together again and she pumping sweet …must have been air lock aye bizzare i checked all of that but could not see a problem at time ohh well all good thanks sooty and all others that replied many thanks and kind regards dan

yeeeep just found pressure hose missing internal seal so i had hose from pump to sluice hopper missing seal…sucking air

Iv been caught out with that as well , its a real bitch generally they sit inside the wee coupling but now & again come out , I always carry a decent carry case with spear , pull cord , spark plug , seals , brass fittings for the air line , nuts and bolts a good socket set , and tape they use for bailage bails its real handy stuff especially if you get a split in a hose, had the rubber foot valve seals perish as well …very frustrating when they go !! , if you,r off the grid take a spear mask as well , iv lost track of how many rubber straps that hold the face mask on , eventually they break too , something else to take if your running a compressor is a spear pulley belt the type that is made of links danny dore sells them expensive but awesome.

1 Like

Process of elimination man:

  1. Check intake hose- Could be pin head hole leak or tear in ribs of hose. Fill intake hose with water ( Foot valve will prevent water escaping) - If leaking water then there is the problem. If your leaking water past foot valve- Get yourself a new foot valve - The Jobe ones Dan Gerber sells are excellent and are more expensive than Keene. I find the Keene foot valves do allow rocks into your pump and also be plastic tend to float easier.
  2. If not intake hose- Must be pump. If the pump is leaking water when it runs it wont prime. If water is leaking at the shaft its your main drive seal (ceramic easy to get) if leaking around housing then just use gasket cement.
    Also check inlet eye (bit hose attaches to on pump) they can crack meaning air will enter system. (use duck tap and fill housing with water if it leaks theirs your problem.

Without telling you to suck eggs also remember to prime your pump with discharge or blaster port open so as to allow air to escape while pump fills with water

1 Like

awesome bit of advice yea i pulled pump apart and see that the o ring orange was slightly damaged put min silicone put back together and it worked for a couple of minitues then back to same problem not sucking water so i have also noticed water driping from front plate ever since i had it and i have probebly done only 5hours max from brand new…i did process of elimination and it comes back to the pump your info has helped me 10 fold thanks so much mate …

1 Like

you have left me some very valuable info thanks a whole bunch sooty you a top man i take your advice for sure cheers mate

No problems man. Glad you got it sorted!

1 Like